[Win] [NB] REST API 401 Unauthorized

PhantomBot Version: 3.1.2 NB 20200418
OS Version: Win10
Java Version: SE 14.0.1
Stock PhantomBot: Yes

When I try to make an API call to, e.g.
http://localhost:25000/dbquery?table=tableName&getSortedRows&webauth=WEBAUTH_TOKEN
I get a 401 Unauthorized no matter what.

Things I tried:

  • Using 127.0.0.1 instead of localhost
  • renaming the webauth token in botlogin.txt
  • removing the webauth token then restart the bot (as suggested in Option to toggle oauth for websocket possible?)
  • Passing token via XHR headers
  • Using incognito mode
  • Using an entire different browser

All of these did not work. Am I missing something? I can’t continue developing without data.

Thanks!

Sorry, I was unable to reproduce. You are sure you are using the webauth value from botlogin.txt and NOT the webauthro?

Yes.

Eventually I tried installing a new instance of Phantombot with new base port and that solved the issue. But I still want to find out why I can’t make it work with the other instance. I’ll report back once I find out stuff.

By the way, when removing the webauth setting from botlogin.txt and restarting the bot no new token is being generated or written into botlogin.txt.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.