!Timer has stopped working!

as written in the discord, the auto post timer no longer works for me. same topic has already been addressed under the following url Timer has stopped working but ignored.

error log in core error folder

[05-21-2020 @ 16:30:21.593 MESZ] org.mozilla.javascript.EcmaError: TypeError: Cannot call method “say” of undefined (misc.js#156)
at org.mozilla.javascript.ScriptRuntime.constructError(ScriptRuntime.java:3951)
at org.mozilla.javascript.ScriptRuntime.constructError(ScriptRuntime.java:3929)
at org.mozilla.javascript.ScriptRuntime.typeError(ScriptRuntime.java:3962)
at org.mozilla.javascript.ScriptRuntime.typeError2(ScriptRuntime.java:3981)
at org.mozilla.javascript.ScriptRuntime.undefCallError(ScriptRuntime.java:3998)
at org.mozilla.javascript.ScriptRuntime.getPropFunctionAndThisHelper(ScriptRuntime.java:2414)
at org.mozilla.javascript.ScriptRuntime.getPropFunctionAndThis(ScriptRuntime.java:2407)
at org.mozilla.javascript.gen.misc_js_2._c_say_10(misc.js:156)
at org.mozilla.javascript.gen.misc_js_2.call(misc.js)
at org.mozilla.javascript.optimizer.OptRuntime.call1(OptRuntime.java:32)
at org.mozilla.javascript.gen.noticeSystem_js_165._c_sendNotice_3(noticeSystem.js:93)
at org.mozilla.javascript.gen.noticeSystem_js_165.call(noticeSystem.js)
at org.mozilla.javascript.optimizer.OptRuntime.callName0(OptRuntime.java:74)
at org.mozilla.javascript.gen.noticeSystem_js_165._c_anonymous_7(noticeSystem.js:336)
at org.mozilla.javascript.gen.noticeSystem_js_165.call(noticeSystem.js)
at org.mozilla.javascript.ContextFactory.doTopCall(ContextFactory.java:393)
at org.mozilla.javascript.ScriptRuntime.doTopCall(ScriptRuntime.java:3282)
at org.mozilla.javascript.gen.noticeSystem_js_165.call(noticeSystem.js)
at org.mozilla.javascript.Context$1.run(Context.java:490)
at org.mozilla.javascript.Context.call(Context.java:501)
at org.mozilla.javascript.Context.call(Context.java:488)
at org.mozilla.javascript.JavaAdapter.callMethod(JavaAdapter.java:576)
at adapter1.run()
at java.base/java.util.TimerThread.mainLoop(Timer.java:556)
at java.base/java.util.TimerThread.run(Timer.java:506)

error log in stacktraces folder

[05-21-2020 @ 16:27:34.842 MESZ] org.mozilla.javascript.EcmaError: TypeError: Cannot call method “say” of undefined (misc.js#156)
at org.mozilla.javascript.ScriptRuntime.constructError(ScriptRuntime.java:3951)
at org.mozilla.javascript.ScriptRuntime.constructError(ScriptRuntime.java:3929)
at org.mozilla.javascript.ScriptRuntime.typeError(ScriptRuntime.java:3962)
at org.mozilla.javascript.ScriptRuntime.typeError2(ScriptRuntime.java:3981)
at org.mozilla.javascript.ScriptRuntime.undefCallError(ScriptRuntime.java:3998)
at org.mozilla.javascript.ScriptRuntime.getPropFunctionAndThisHelper(ScriptRuntime.java:2414)
at org.mozilla.javascript.ScriptRuntime.getPropFunctionAndThis(ScriptRuntime.java:2407)
at org.mozilla.javascript.gen.misc_js_2._c_say_10(misc.js:156)
at org.mozilla.javascript.gen.misc_js_2.call(misc.js)
at org.mozilla.javascript.optimizer.OptRuntime.call1(OptRuntime.java:32)
at org.mozilla.javascript.gen.noticeSystem_js_165._c_sendNotice_3(noticeSystem.js:93)
at org.mozilla.javascript.gen.noticeSystem_js_165.call(noticeSystem.js)
at org.mozilla.javascript.optimizer.OptRuntime.callName0(OptRuntime.java:74)
at org.mozilla.javascript.gen.noticeSystem_js_165._c_anonymous_7(noticeSystem.js:336)
at org.mozilla.javascript.gen.noticeSystem_js_165.call(noticeSystem.js)
at org.mozilla.javascript.ContextFactory.doTopCall(ContextFactory.java:393)
at org.mozilla.javascript.ScriptRuntime.doTopCall(ScriptRuntime.java:3282)
at org.mozilla.javascript.gen.noticeSystem_js_165.call(noticeSystem.js)
at org.mozilla.javascript.Context$1.run(Context.java:490)
at org.mozilla.javascript.Context.call(Context.java:501)
at org.mozilla.javascript.Context.call(Context.java:488)
at org.mozilla.javascript.JavaAdapter.callMethod(JavaAdapter.java:576)
at adapter1.run()
at java.base/java.util.TimerThread.mainLoop(Timer.java:556)
at java.base/java.util.TimerThread.run(Timer.java:506)

I’m not all too familiar with the code base, but to me this looks like the bot might not be connected properly to twitch. Is the rest of the bot working (e.g. custom commands)?

I haven’t noticed anything yet. I also posted pictures in the discord as proof