Raspberry pi Websocket

PhantomBot Version: 3.0.0
OS Version: Raspbian Stretch
Java Version: 1.8.0_181
Browser and Version (for Panel Support): Firefox 65.0.2
Stock PhantomBot: Yes

I recently updated my Raspberry Pi3 to Stretch and also reinstalled Phantombot 2.4.2.1(was previously running v2.3.7.1 successfully). Had all my login info filled out, the bot was/is in my discord server but I am unable to gain access to the panel/beta-panel.

I’ve checked and double checked to make sure that I had the correct ports open in ufw.
Last night, I saw that version 3.0.0 was released, so I thought that may fix my issue.

But, sadly, still no connection.

I did notice several error logs in the phantombot directory that mention a fatal error in the Java Runtime Environment.

If you are having troubles connecting to a port, you might need to debug the port and sniff for traffic.

You could provide the error logs and we can see if anything stands out with regards to Java. On Raspbian, we only recommend using the Oracle version of Java 8.

For reference, this is my Raspberry Pi running Jesse, note that I do not have iptables or firewalld installed.

illusion% cat /etc/*release*
PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
[03-06-2019 @ 03:23:45.420 GMT] The working directory is: /opt/iobot
[03-06-2019 @ 03:23:45.421 GMT] Detected Java 1.8.0_144 running on Linux 4.9.24-v7+ (arm)
[03-06-2019 @ 03:23:45.720 GMT]
[03-06-2019 @ 03:23:45.722 GMT] PhantomBot Version: 3.0.0
[03-06-2019 @ 03:23:45.723 GMT] Build Revision: 0c9b8c3
[pomona] /opt/iobot
illusion% java -version
java version "1.8.0_144"
Java(TM) SE Runtime Environment (build 1.8.0_144-b01)
Java HotSpot(TM) Client VM (build 25.144-b01, mixed mode)
[03-05-2019 @ 20:29:16.450 MST] For support please visit: https://community.phantombot.tv
[03-05-2019 @ 20:29:16.450 MST]
[03-05-2019 @ 20:29:16.470 MST] Connecting to Twitch WS-IRC Server (SSL) [irc-ws.chat.twitch.tv]
[03-05-2019 @ 20:29:16.806 MST] Connected to [email protected] (SSL)
[03-05-2019 @ 20:29:16.884 MST] Channel Joined [#notillusionaryone]
[03-05-2019 @ 20:29:20.200 MST] illusionarybot ready!
[03-05-2019 @ 20:29:20.884 MST] Connected to Twitch Host Data Feed
[03-05-2019 @ 20:29:22.840 MST] [CHAT] Test Notice 1
^Z
[1]+  Stopped                 ./launch.sh
[pomona] /opt/iobot
illusion% hostname
pomona

Note that I use port 27000 for testing:

Sorry for the delayed post, I went without power and totally forgot to check back.

I stumbled across an image that I backed up of Jessie lite with Phantombot 2.3.7.1 working on it.

I updated to 3.0.0 and it works. I have no idea why because I followed the same guide.

I do need to take another Pi and try out the newer versions of Raspbian, just have not had an opportunity to. Let us know if Jessie seems to take care of the issue. Since that is the version that I run with, sadly, that is the only version that I can really support/comment on.

Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.