Question about the keystore and httpsFileName with respect to SSL connections

I’m currently getting this error when trying to launch my bot after going through the SSL configuration guides:

[02-12-2020 @ 02:28:01.925 GMT] Detected Java 1.8.0_242 running on Linux 4.15.0-76-generic (amd64) 
[02-12-2020 @ 02:28:02.106 GMT]  
[02-12-2020 @ 02:28:02.108 GMT] PhantomBot Version: 3.0.0
[02-12-2020 @ 02:28:02.109 GMT] Build Revision: fcc08b51
[02-12-2020 @ 02:28:02.109 GMT] Creator: mast3rplan
[02-12-2020 @ 02:28:02.110 GMT] Developers: PhantomIndex, Kojitsari, ScaniaTV, Zackery (Zelakto) & IllusionaryOne 
[02-12-2020 @ 02:28:02.111 GMT] https://phantombot.tv/
[02-12-2020 @ 02:28:02.111 GMT]
[02-12-2020 @ 02:28:02.123 GMT] [ERROR] [<init>()@PhantomBot.java:456] HTTPS is enabled but the Java Keystore (httpsFileName) is not defined. 
[02-12-2020 @ 02:28:02.124 GMT] [ERROR] [<init>()@PhantomBot.java:457] Terminating PhantomBot

However, I put the keystore in the same config folder that botlogin.txt is in, and according to the guide:

If you place the keystore.jks file in your PhantomBot directory, you do not need the path.

And even when adding the path, I get the same error anyway?

[02-12-2020 @ 02:31:57.987 GMT] Detected Java 1.8.0_242 running on Linux 4.15.0-76-generic (amd64)
[02-12-2020 @ 02:31:58.160 GMT]  
[02-12-2020 @ 02:31:58.161 GMT] PhantomBot Version: 3.0.0 
[02-12-2020 @ 02:31:58.162 GMT] Build Revision: fcc08b51
[02-12-2020 @ 02:31:58.162 GMT] Creator: mast3rplan
[02-12-2020 @ 02:31:58.163 GMT] Developers: PhantomIndex, Kojitsari, ScaniaTV, Zackery (Zelakto) & IllusionaryOne
[02-12-2020 @ 02:31:58.163 GMT] https://phantombot.tv/ 
[02-12-2020 @ 02:31:58.164 GMT]
[02-12-2020 @ 02:31:58.174 GMT] [ERROR] [<init>()@PhantomBot.java:462] HTTPS is enabled but the Java Keystore (httpsFileName) is not present: ~/phantombot/config/keystore.jks
[02-12-2020 @ 02:31:58.175 GMT] [ERROR] [<init>()@PhantomBot.java:463] Terminating PhantomBot

My directory looks like this:

[email protected]:~/phantombot/config$ ls -a 
.  ..  audio-hooks  botlogin.txt  gif-alerts  keystore.jks  phantombot.db  phantombot_points.csv

Maybe I’m missing something here, but should I be using direct paths to files and not the ~ shorthand? Why do I even need to add a path if it’s in the same directory as botlogin.txt?

Edit: I realize I didn’t add in my botlogin file, here it is with the extra bits cut out:

....
usehttps=true
httpsPassword=(itsasecret)
httpsFileName=~/phantombot/config/keystore.jks
.....