Problems installing in windows 10

PhantomBot Version: 3
OS Version: win 10
Java Version: 8
Browser and Version (for Panel Support):
Stock PhantomBot: Yes

Let us know what help you need: trying to run initial setup and after i put in the tokens and such, i get all this jibberish that says it can’t find files, please see pic…

If a feature is not working, please provide console output, output from chat, logs, some sort of additional information to help us troubleshoot and provide assistance as needed:

More than likely a permission issue did not allow the directories to be created. If you look in the logs folder, you probably will not find a core-error directory.

Did you install into an open directory or did you attempt to place into an administrator controlled directory, like “Program Files”? Unfortunately, you cut that part out in the screenshot. For example:

[04-02-2019 @ 23:39:09.167 GMT] The working directory is: /usr/local/opt/iobot
[04-02-2019 @ 23:39:09.171 GMT] Detected Java 1.8.0_102 running on Linux 4.8.13-100.fc23.x86_64 (amd64)
[04-02-2019 @ 23:39:09.236 GMT] Enabling Script Reloading
[04-02-2019 @ 23:39:09.236 GMT] Enabling Silent Script Load

The first Console message would let me know where PhantomBot is running from.

i dinna see it say anything like that… but i did put it under program files

ok, yeah… moved it outta program files and it works great, thankies @IllusionaryOne

If you installed the bot in Program Files but did not Run As Admin then there will definitely be permission issues.

There are two ways you can fix the issue

  1. You can move the bot to your Documents folder, where permissions will not be a concern (Reccomended)
  2. You can Run as Administrator

If you want to go route 2, you can either right-click and hit Run as Administrator every time or you can edit the properties to make it always Run as Administrator by default.

  1. Right-Click launcher script
  2. Click Properties
  3. Click the Compatibility tab
  4. Check off Run this program as an Administrator
  5. Click OK

Note that UAC (The Do you want to allow app to make changes to your computer popup) will appear every launch if running as Administrator

actually i tried run as admin, but when i did that it told me it couldn’t access the jar file… which made no sense since i was looking right at it… but i just moved it and it worked ^^

@IllusionaryOne Suggest updating Windows Setup Guide to mention that installing to Documents is recommended to avoid permission issues and add a section near the bottom mentioning that if you get upon launch that it is most likely a permission issue and how to fix

Some changes might need to be made to the launcher script to address that Run as Administrator thing, thanks for mentioning that

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.