Phantombot won't compile properly, and I can't find the proper library to update it with (Fresh Download)

PhantomBot Version: None, Can’t Compile Phantombot, Attempting to use 3.0 Stable
OS Version: Windows 10 Version 1903, Build 18362.535
Java Version: Recommended Version 8 Update 231
Browser and Version (for Panel Support): 79.0.3945.88 (Official Build) (64-bit)
Stock PhantomBot: Yes

Let us know what help you need:

I am receiving the error documented in the following thread.

[Cannot compile phantombot because it shows errors on running](http://Can’t Compile Phantombot)

My problem is that A) this is a fresh download, and I’m unsure why something from the library would be missing. Partly I make this to potentially warn you (as someone who just discovered phantombot 2 minutes ago) in case this was not a mistake on my part (which is likely is).

And B) I have NO idea where to find the “PhantomBot/dist/build/lib (from the build area)”. Rudimentary Google-fu isn’t helping me divine it’s location, and I searched through everything in the download.

I made sure to follow every step in the Windows Set Up Guide JUST to be sure I hadn’t missed anything. I’m almost positive I’m missing something horrendously simple, and if that’s the case, I apologize.

Thanks in advance for your time.

EDIT: Running the bat file in administrator mode produces the ‘Unable to access Phantombot.jar file’ error as documented in this link. Unable to access Jar File .

I made doubly sure to follow the instructions in that post. The files are extracted, in their own folder on my desktop. I made doubly sure to install java and reboot several times to allow it to take. The Jar file is on the same page at the bat file.

Can you please post an exact copy of the commands you used to compile and their output, as well as the exact output of the attempt to run the bat file?

Truth be told, I simply tried to run the batch file by double clicking or right clicking it. Just now, I attempted to run the path through the command prompt (as an administrator). Same result.

Output for running manually through command prompt (as administrator)

C:\WINDOWS\system32>C:\Users\alto0\Desktop\ContentProduction\PhantomBot-3.0.0\launch.bat
Error: Unable to access jarfile PhantomBot.jar
Press any key to continue . . .

Output for running normally

Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object
Press any key to continue . . .

Output for running as administrator

Error: Unable to access jarfile PhantomBot.jar
Press any key to continue . . .

Try

  1. Completely uninstall all versions of Java and the JDK
  2. Delete java.exe from C:\Windows\System32 (If this file is missing, skip this step)
  3. Restart the computer (Make sure you actually select the Restart option in Windows)
  4. Re-download Java from 64-bit Java for Windows
  5. Install from the fresh download