Phantombot is not able to post on Discord even though it authenticates fine

PhantomBot Version: 3.0.0
OS Version: Linux
Java Version: 1.8.0_131-b11
Browser and Version (for Panel Support): Google Chrome Version 75.0.3770.142 (Official Build) (64-bit)
Stock PhantomBot: Yes

I am running PhantomBot on a Raspberry Pi 4 and it will not respond to any commands or post anything on Discord. It randomly stopped working a few weeks back.

I have tried using the nightly build, switching to the most recent version of Oracle Java 8, remaking the bot in the Discord developer panel, resetting the bot key, reinstalling Raspbian, even using a different Raspberry Pi (3B+) but nothing has helped. When the Pi boots, the bot starts up and automatically connects to Twitch, working fine there but will not appear in Discord. Forcing the bot to quit and manually running the launch script lets it pop up in Discord but it will not respond to any commands or post anything in any channels.

There are no reported errors about authentication or anything else in the console when it launches.

I got this problem too. But after using the newest nightly it worked again

I have tried multiple nightly builds including the current one but nothing has changed.

Maybe create a new API Key for Discord

I’ve reset the bot token and also deleted the bot from the Discord dev panel and remade it. Neither helped.

No one has any other suggestions? I’m at a total loss here.

Used this to resolve the issue with my bot boi

No luck for me. Made no difference.

Absolutely no support on this issue? I’m sure it’s specific to the Raspberry Pi.

I just tested on my Raspberry Pi.

[pomona] /opt/iobot
illusion% ./launch.sh
[09-04-2019 @ 00:16:06.388 GMT] The working directory is: /opt/iobot
[09-04-2019 @ 00:16:06.389 GMT] Detected Java 1.8.0_144 running on Linux 4.9.24-v7+ (arm)
....
[09-03-2019 @ 18:18:49.354 MDT] [DISCORD] [#bottest] illusionaryone: !picommand
[09-03-2019 @ 18:18:49.364 MDT] [DISCORD] [#bottest] [CHAT] This is running from a Raspberry Pi.

It is working from my Pi:

illusion% uname -a
Linux pomona 4.9.24-v7+ #993 SMP Wed Apr 26 18:01:23 BST 2017 armv7l GNU/Linux
[pomona] /opt/iobot
illusion% cat /etc/*release*
PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
[pomona] /opt/iobot
illusion% java -version
java version "1.8.0_144"
Java(TM) SE Runtime Environment (build 1.8.0_144-b01)
Java HotSpot(TM) Client VM (build 25.144-b01, mixed mode)

Is there anything in the logs directory, in the stacktrace or errors? Not everything goes to the Console.

Apologies for the delay, been traveling to Twitch HQ and Vegas for work then took a 2.5 week vacation after that. After catching up at work, we had Labor Day weekend :slight_smile:

No problem, I understand!

Found this in core-error logs:

[09-04-2019 @ 00:25:50.611 GMT] java.io.IOException: Input/output error
at java.io.FileInputStream.readBytes(Native Method)
at java.io.FileInputStream.read(FileInputStream.java:255)
at java.io.BufferedInputStream.read1(BufferedInputStream.java:284)
at java.io.BufferedInputStream.read(BufferedInputStream.java:345)
at sun.nio.cs.StreamDecoder.readBytes(StreamDecoder.java:284)
at sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:326)
at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:178)
at java.io.InputStreamReader.read(InputStreamReader.java:184)
at java.io.BufferedReader.fill(BufferedReader.java:161)
at java.io.BufferedReader.readLine(BufferedReader.java:324)
at java.io.BufferedReader.readLine(BufferedReader.java:389)
at com.gmt2001.Console.in.readLine(in.java:36)
at tv.phantombot.console.ConsoleInputListener.run(ConsoleInputListener.java:31)

[09-04-2019 @ 00:26:13.788 GMT] [connect()@DiscordAPI.java:120] Failed to authenticate with Discord: [DiscordException] Exception (NullPointerException) occurred while logging in: null

[09-04-2019 @ 00:27:31.127 GMT] org.mozilla.javascript.EcmaError: TypeError: Cannot call method “isLoggedIn” of null (misc.js#52)
at org.mozilla.javascript.ScriptRuntime.constructError(ScriptRuntime.java:3951)
at org.mozilla.javascript.ScriptRuntime.constructError(ScriptRuntime.java:3929)
at org.mozilla.javascript.ScriptRuntime.typeError(ScriptRuntime.java:3962)
at org.mozilla.javascript.ScriptRuntime.typeError2(ScriptRuntime.java:3981)
at org.mozilla.javascript.ScriptRuntime.undefCallError(ScriptRuntime.java:3998)
at org.mozilla.javascript.ScriptRuntime.getPropFunctionAndThisHelper(ScriptRuntime.java:2414)
at org.mozilla.javascript.ScriptRuntime.getPropFunctionAndThis(ScriptRuntime.java:2407)
at org.mozilla.javascript.optimizer.OptRuntime.callProp0(OptRuntime.java:83)
at org.mozilla.javascript.gen.misc_js_139._c_isConnected_3(misc.js:52)
at org.mozilla.javascript.gen.misc_js_139.call(misc.js)
at org.mozilla.javascript.optimizer.OptRuntime.callProp0(OptRuntime.java:85)
at org.mozilla.javascript.gen.roleManager_js_145._c_roleUpdateCheck_3(roleManager.js:34)
at org.mozilla.javascript.gen.roleManager_js_145.call(roleManager.js)
at org.mozilla.javascript.ContextFactory.doTopCall(ContextFactory.java:393)
at org.mozilla.javascript.ScriptRuntime.doTopCall(ScriptRuntime.java:3282)
at org.mozilla.javascript.gen.roleManager_js_145.call(roleManager.js)
at org.mozilla.javascript.Context$1.run(Context.java:490)
at org.mozilla.javascript.Context.call(Context.java:501)
at org.mozilla.javascript.Context.call(Context.java:488)
at org.mozilla.javascript.JavaAdapter.callMethod(JavaAdapter.java:576)
at adapter1.run()
at java.util.TimerThread.mainLoop(Timer.java:555)
at java.util.TimerThread.run(Timer.java:505)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.