Panel not opened for me

#1

PhantomBot Version: 2.3.9
OS Version: CentOS 7
Java Version: 1.8

Hello. I have the problem, that I have got my Bot running, but I can not access the panel. It is simply not opened to Me.

#2

Hey, I see that you’re running the bot on Centos 7, did you open the ports required for the panel to work?

You can learn more about this here: PhantomBot Control Panel

1 Like
#3

So I have to open the ports themselves on the VServer? Ok then I’ll do it

#4

Yes, and depending on your host, you might have to open them on their dashboard as well.

1 Like
#5

My server is running ZAP hosting

#6

You might need to check the firewall setup in CentOS as well as with Zap Hosting. If they have a support team, that is the best way to go. For information about configuring firewalls in CentOS, it depends if you are using firewalld or iptables. The default should be firewalld, so here are some instructions for that:

https://www.rootusers.com/how-to-open-a-port-in-centos-7-with-firewalld/

You will need to use the --permanent --add-port option I believe.

1 Like
#7

This might help you.

sudo firewall-cmd --status - Make sure it is enabled.
sudo firewall-cmd --zone=public --permanent --add-port=25000-25004/tcp
sudo firewall-cmd --reload

Hope this helps!

#8

Thank yes.

closed #9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.