Mod commands responding in chat not whisper


When using the checkfollow and permissionlist commands, whispering to the bot, the response is printed back into chat, instead of whispering back to the sender.

In the case of permissionlist, this is just messy and is information that the majority of chat doesn’t care about, it’s chat bloat, should be bounced back to the moderator who sent it.

In the case of checkfollow, this is potentially part of background checking on a potential troll or malicious actor, having that response in chat seems like it could aggravate someone.

Both are built in commands, so I can’t just add /w (sender) to the front and have it reply that way. Could we have these set to default to whisper the sender, even when not in whisper mode.

I’m currently on a nightly build, but I’ve also checked this on a friend’s bot running the latest stable build with the exact same result.

The bot will always respond in chat even if you whisper it, you’d need to turn on whisper mode for this to work properly, it’s not meant for it to know where the message came from, that just slows things down.

Yeah, forgot to check this while making the initial post. The bot is already in whisper mode. Everything else I’d expect to whisper is doing so, including commands, addcom, editcom etc…

This only works with scripts that start with $.whisperPrefix(sender) in the $.say()

function whisperPrefix(username, force) {
    if (whisperMode || force) {
        return '/w ' + username + ' ';
    return '@' + $.username.resolve(username) + ', ';

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.