I'm having trouble turning on timers and other modules

PhantomBot Version: 3.0.0
OS Version: MSWin 10 64bit
Java Version: 8 Update 201
Chrome 73.0.3683.103 (Official Build) (64-bit)
Stock PhantomBot: Yes

Let us know what help you need:
I can not turn on any modules like Timers and Keywords… the toggle switch is grayed out on both their tabs.
Even if I go down to settings/modules and activate one like Keywords, that one is still grayed out under its tab.
I do not see the option to turn on Timers in the module listing under settings at all.
there are no logs to this…it is simply not available to be turned on or off for me…
I would assume since i’m kind of new at this I am missing something… just not sure what that could be.

FYI when I click the Timers tab I see for the briefest moment (less than a second) the “add timer” button in green and the toggle switch is on…then it flashes away and I can not change the state of the toggle switch under Keywords or Timer.

module enable ./handlers/keywordHandler.js
module enable ./systems/noticeSystem.js
in the console

The command console…DOH…sorry I’ve always referred to it as command window …LUL
I dug around a bit and tried to use those scripts and neither worked…
I’m assuming i’m doing it in the wrong directory …
I’ve posted them in the phantombot folder and such…I’m extremely rough on this…I used to use DOS like 20 years ago a lot…but I’ve been on a Mac now for about that long… and Java is still a foreign language to me. any help would be superb and greatly appreciated.
Looking in my phantombot folder I can find the timers JS file…but its still not enabling it.
I’m at a loss on this

This is called the bot console in Terminal.app on macOS

Only thing that could cause this is a permission issue.

Make sure to chown the bot’s directory to the user that it’s running the bot. Do this while the bot is off.

sudo chown -R user_runningbot:user_runningbot /path/to/bot/folder

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.