Error with event handler when trying to use a keyword response

[06-20-2019 @ 21:53:26.069 GMT]
Java Version: 1.8.0_201-b09
OS Version: Windows 10 10.0 (amd64)
Panel Version: 1.0.0
PhantomBot Version: 3.0.0 (Revision: 3ce4a854)
Browser: Chrome
Stock PhantomBot: No

I am trying to enable a keyword response to that the bot replies to a keyword (i.e. the command does not need to be first)

From the panel i click on Keywords, then enabled it, then added a keyword. lets say the keyword is test. i then added a response. i did not check regex.

When the keyword is used in chat the bot does not respond, but i see the following error logged in the console:

[ERROR] [init.js:325] Error with Event Handler [ircChannelMessage] Script [./handlers/ke > init.js:436] Exception [TypeError: Cannot find function getArgs in object [email protected]]

Is this a known issue or does the error make sense to anyone?

What is the response you put in for this keyword?

i was using the keyword within the response, which seemed to cause this error.
once i removed the keyword from the reply it seemed to work fine.

so apparently you cant use the keyword in the response?

I need full information on the actual responses you setup so I can trace the code execution path And figure out what went wrong. if you need to obfuscate the actual names and text that’s fine but make it perfectly equivalent

super weird, its working now. i cannot get the error to trigger again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.