Error when connecting to Youtube player

#1

This error pops up in the console when trying to connect to YouTube player: [ERROR] [init.js:325] (http://hook.call , yTPlayerState, ./systems/youtubePlayer.js) No data returned.

I have managed to mark it down to only happening when I disconnect from the servers remote desktop, if I stay connected, youtube player works. If I disconnect, and yt player stops working, bot needs to be restarted to fix.

My guess is that its nothing wrong with the bot itself, but the fact that the bot cannot run properly when user isn’t connected to the server?

#2

Does anything else stop working when you disconnect from the server? Such as the panel or command responses?

What VPS are you using if any?

#3

No, only the YouTube player. Sometimes the entire bot freezes, and only unfreezes when I connect to the remote desktop to the server & type a letter in the console (don’t have to send, just type)

No “VPS”, I am using it off a server computer self hosted with a Remot Desktop connection to it.

#4

I get the same error after trying to launch the YT player (just started recently, and persists after updating. I was using PhantomBot 2.4.1-NB-20180625 for a while and was working fine till i’d say a few days ago)

It says “Video not allowed to be embedded” but the ID isn’t something in my playlist. Could it be one of the “starter” songs that came with the YT player that’s causing it?

Update: i tried changing the YT Video ID in the Youtube.js but it still gives me “video cannot be embedded”. Could the API for YT have changed recently?

#5

@icecold960 have a look at this post here;

There have been issues with keeping their own key for everyone to utilize so they’d like if you have your own key. Your issues should resolve after that, I’d assume.

#6

Yes this was it, thank you for helping me fix it!

1 Like
#7

No. This was not a solution for me, I already got a YouTube API key from long ago.
The issue seems to be not the YouTube player, but the bot itself just randomly freezing at some points, where you have to go and refresh it to work again by just clicking in the CMD console and just typing 1 letter.

#8

Sounds like you’re leaving the command prompt in a state that’s waiting for input. It’s a pretty common occurrence that people run into when using rdp. If you Google something like “command prompt freezes until input” quite a few postings across different sites come up.

#9

Oh okay, I just found out the other guy on the server hasn’t been using the disconnect.bat file I made (that keeps the user logged while disconnecting from RD).

Thank you!

1 Like
closed #10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.