Discord live notification isn't working

PhantomBot Version: 3.0.0
OS Version: Windows Server 2019 (version 1809)
Java Version: 8 Update 231
Browser and Version (for Panel Support): Chrome 79.0.3945.117
Stock PhantomBot: Yes

Let us know what help you need:
Got my bot up and running again after a long time, but don’t get a live notification on Discord and an error in the console. I updated every key, oauth and what not.

If a feature is not working, please provide console output, output from chat, logs, some sort of additional information to help us troubleshoot and provide assistance as needed:
[01-12-2020 @ 02:56:47.612 GMT] [ERROR] [init.js:325] Error with Event Handler [twitchOffline] Script [./discord/handler > init.js:860] Exception [JavaException: java.lang.NullPointerException: null]

Thanks in advance!

hi, could you replace your discord4J-2.10.1-shaded.jar with this one? PhantomBot/Discord4J-2.10.1-shaded.jar at df7d35e2831a0169e94e5c2e212a494e6746e13d · PhantomBot/PhantomBot · GitHub for me it worked direct and its worth a try :slight_smile:

Gonna test this later this day when I’m live again. Thanks for the fast response!

I tried installing this on a ubuntu server and now I can’t launch the bot at all. Is this specific to a certain OS?

what did you try to install? maybe give some steps about it? more information?

I shut down the bot installed the jar you linked in my lib folder. went to boot it back up after words and it wouldn’t take. I tried reinitialize the launch files to make sure they worked, but alas it still won’t launch. I currently have it running without the new file.

Edit -
For some reason I needed to assign the right privileges to make the launch.sh and launch-service.sh files executable again. Not sure why this was needed, but very annoying that it was part of the process. Hopefully this will help someone else that is updating this on ubuntu as well. Also make sure to switch the old .js file before continuing on.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.