Discord Integration works on one Server but doesn't work on another

Hello,
first of all the discord bot worked for a long time, and somehow stopped working for no obvious reason.
What i tried:

  1. Refreshed the bot token, but still didn’t work.
  2. Searched logs for errors regarding discord, but found nothing useful.
  3. Searched console output for Discord - says Discord Authentication successfully
  4. Looked up if discord messages get logged in the console output. They get logged only on a new server but not on the server where it worked on.
  5. Made a new Discord application and a new bot. Invited the bot on both servers. Still worked on the new server but not the old.
  6. CustomCommands, ClipHandler etc. are working on the new server but not on the old.

TL;DR
Bot works on any new Server but doesn’t work on the one it worked on before.
Any idea why?

I appreciate your help!

Edit:
I installed a clean installation locally, the new fresh installation works on any server but not the one it should work on. How is this possible? The Bot has rights ro read and write on the server, he basically has any permission cause he is a administrator.

It was the excact same issue as this one Error with discord bot