Custom commands without "!"

PhantomBot Version: PhantomBot Version: 3.0.0
OS Version: Mac OS X 10.15 (x86_64)
Java Version: Java 1.8.0_231
Browser and Version (for Panel Support): Chrome - Latest
Stock PhantomBot: Yes/No (Yes if you have not modified the scripts or Java Core) Yes

Let us know what help you need:

How can I disable the “!” before commands so that they can be run without using it or using a different prefix such as “?”. I cant find the option in settings anywhere.

If a feature is not working, please provide console output, output from chat, logs, some sort of additional information to help us troubleshoot and provide assistance as needed:

You would have to make a modification on the Java side and recompile the bot yourself

The relevant lines of code can be viewed here: PhantomBot/TwitchWSIRCParser.java at master · PhantomBot/PhantomBot · GitHub

Did you find any permanent solution as of now? Even looping seems not to work for me.

Regards,
Nasaka Smith https://plex.software/ https://tutuappx.com/ Vidmate

So for anyone looking for a solution, I found a workaround that seems to work.

Go to Settings and click on Modules. Then in the search box in the top right type in “Keywords”. Enable the module that comes up and the page should refresh. In the left sidebar you should now see a new menu item for “Keywords” Click that and add any commands you want.

Keywords work very similar to commands except they don’t automatically add an exclamation mark (!) to the commands. The response will trigger after anything in the keyword box is typed in chat.