Bug ImportPL YT

#1

Failure to fill out the requested information will result in us asking for it or closing the ticket as incomplete. This include logs and screenshots as requested.

The Nightly Version is not supported! Please open a topic under Nightly Build > Bug Reports.

To provide the bot information below, you can simply type botinfo in your bot console and hit enter. That will print the bot’s general information. Version 2.4.0+ you may get the versions from the Information panel.

Please remove this line and the lines above to make it less confusing for other users.

PhantomBot Version: 2.4.0.1 (Revision: a532ab64)
OS Version: Linux Raspbian 8
Java Version: 1.8.0_u161-b12
Browser and Version (for Panel Support): Version 64.0.3282.167 (Official Build) (64-bit)
Stock PhantomBot: Yes
Any Recent Changes to Your System: Yes

Description of Issue:
Cannot ImportFile YT

Console logs or log file entries:

no error… Is stuck on “Import has started, please wait…”

#2

hey i think this is the same bug:

#3

I have update to NB, but now ytplayer is not starting anymore and I got this error:

02-15-2018 @ 12:13:37.273 GMT] [init.js:308] (hook.call, yTPlayerState, ./systems/youtubePlayer.js) TypeError: Cannot call method “say” of undefined
[02-15-2018 @ 12:14:03.703 GMT] [init.js:300] (hook.call, command, ./systems/youtubePlayer.js) ReferenceError: “readFile” is not defined.

#4

ytplayer is stuck on loading circle… the module is active

#5

You did a fresh install when you updated to the nightly correct?

As in you only transferred over the config/database

#6

cancelled every file and add into db file and boot file

#7

Are you talking about the botlogin.txt?

You should only need that, the phantombot.db file, and whatever custom ones you’ve added.

#8

Yep!
into config folder bootlogin.txt and phantombot.db

#9

Could you try an install without the db file?

I just loaded up the nightly and the ytplayer is working on my end.

#10

same problem… probably is a system problem

#11

I think one of the developers will have to get back to you on this issue.

Do you have any log files you can post as well? It would help.

#12

Right, I have fixed ytb loading just loading another playlist! But the first problem still the same, on chat is stuck on Import has started, please wait…

LOG:
[02-15-2018 @ 12:13:37.273 GMT] [init.js:308] (hook.call, yTPlayerState, ./systems/youtubePlayer.js) TypeError: Cannot call method “say” of undefined
[02-15-2018 @ 12:14:03.703 GMT] [init.js:300] (hook.call, command, ./systems/youtubePlayer.js) ReferenceError: “readFile” is not defined.
[02-15-2018 @ 13:10:07.748 GMT] [init.js:308] (hook.call, yTPlayerState, ./systems/youtubePlayer.js) TypeError: Cannot call method “say” of undefined
[02-15-2018 @ 13:16:41.758 GMT] [init.js:308] (hook.call, yTPlayerState, ./systems/youtubePlayer.js) TypeError: Cannot call method “say” of undefined
[02-15-2018 @ 13:28:39.109 GMT] [init.js:300] (hook.call, command, ./systems/youtubePlayer.js) TypeError: Cannot call method “pushPlayList” of null
[02-15-2018 @ 13:30:58.767 GMT] [init.js:300] (hook.call, command, ./systems/youtubePlayer.js) ReferenceError: “readFile” is not defined.

#13

Could you post a copy of the playlist?

And it is located in ./addons/ytplayer/ right?

#14

is in .addons/youtubeplayer/

Phantombot created a playlist, but without song! I’ve checked the song, and are ok! If I add the song one by one with ytplayer everything is fine without problem!

#15

while the media is slightly outdated, this document should help:

It has a guide on how to import a playlist.

#16

I had a lot of playlist imported with the old version and I never had problems to import them! Will see with devs if there is a reason or not, at the end I have solved my issue add the song 1 by 1. Thank for your help!!

#18

Can you type botinfo in your bot console and press enter? Please paste the output here afterwards.

#19

Looks like I never merged the fix. It will be in tomorrow’s nightly.

1 Like
closed #20

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.