Bot not posting when live - API works, Commands work

Hello support!

I am new to PhantomBot and trying out the twitter integration.

I set up everything like here: <0> Twitter Integration Setup
especially the /PhantomBot/config/botlogin.txt
with the following:

I have looked at these two Topics:
<1> Twitter integration wont work
<2> Twitter not posting when live, etc

PhantomBot Version: 3.0.0
Java Version: 8
Stock PhantomBot: Yes

Following problem:
<1> When checking out the loaded module etc I get the line: Authenticated with Twitter API
When trying to use !twitter or more special: !twitter post test
the commands will work.
There is a Tweet immidiatly after firing up the command.
This brought me to the conclusion that the module is working in general.

<2> I have checked if my Twitter-App is being suspended or similar. Nope …
Also when firing up !twitter post test it will work :smiley: so this cannot be the reason.
I also changed the text of the post in order to fight against the Twitter-Filters. Doesn’t work either.

I have configured the Alerts via WebGUI.
About the Twitter Alert Settings:

  1. active
  2. Twitter configuration: all set to No because I don’t need my tweets being posted in the Twitch Chat
  3. Twitter Retweet Configuration: all set to No because there is no usecase atm
  4. Alert Settings: Enable Online Tweet: Yes and the others No, because no need of timed tweets.

Permissions Tab:
Bot has caster permission.
The default !twitter commands are set from Viewers to Adminstrators. (also as mentioned they work).

I configure most of the stuff via WebGUI but am also familar with the console (for support feel free to tell me to fire up some commands :wink: )

Thank you for your attention!


do you have any error’s in the log folder from when you go live?

first: thanks for the quick response! (didn’t expect that)

I checked the core, events, core-error, core-warnings and error logs
No unexpected errors there (only from discord-handler while testing this but everything solved)

btw I will now not be available for about 18 hours (sleep and work) but will read and answer as soon as I can!

Try the following commands (case sensitive)

!module enable ./handlers/twitterHandler.js
!twitter set message online Live with (game)! (twitchurl)
!twitter set post online on

Note that after you go live it may take a few minutes for the API to update and show you online (and therefore cascade into the bot). It is slower than the Twitch site itself

Thank you!!
That has helped! It is working now!

I wonder why this has to be done via commands…
However it worked and this will be noted for future issues :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.